Offer/Loyalty Offer Edits

Incident Report for Incentivio

Resolved

Resolved - The issue affecting item-based offers on the Incentivio Platform has been fully resolved.

The mitigation has been successfully validated, and item-based offers can now be edited and managed normally. Our teams have completed monitoring and confirmed platform performance has returned to expected levels.

We appreciate your patience while we worked to address this issue and thank you for your understanding.

Jun 09, 2026 - 12:40PM EST
Posted Jun 09, 2026 - 13:40 EDT

Monitoring

We’ve implemented a mitigation to address the issue affecting item-based offers on the Incentivio Platform.

We are currently monitoring platform performance and validating offer functionality to ensure item-based offers can be edited and managed normally. Some users may continue to experience intermittent errors when modifying targeted items while the fix is being fully rolled out and validated.

Our teams remain actively engaged and will continue monitoring closely.

Thank you for your patience and understanding.
Posted Jun 09, 2026 - 13:32 EDT

Identified

Editing an item-based offer will show an error message when adjusting targeted items. A fix for this behavior is currently in-progress.
Posted Jun 09, 2026 - 12:59 EDT
This incident affected: Communications (Offer Service).