Platform Service Restored

Incident Report for Incentivio

Resolved

The issue impacting our platform has been resolved, and services have been fully restored.

Our engineering team has confirmed platform stability following recovery efforts and continued monitoring. We appreciate your patience while we worked through this disruption and apologize for the inconvenience.
Posted Apr 29, 2026 - 12:41 EDT

Update

We are continuing to monitor for any further issues.
Posted Apr 29, 2026 - 12:39 EDT

Monitoring

Our database is back online, and platform services are currently recovering. Mobile apps, web ordering, and related services may still experience temporary delays as systems fully stabilize.

Our engineering team is actively monitoring performance to ensure a full recovery. Please allow a few moments for services to fully load and sync.

We appreciate your patience and will continue to share updates as needed.
Posted Apr 29, 2026 - 11:18 EDT

Identified

We’re currently investigating an issue impacting our platform and are aware that some users may be experiencing service disruptions across multiple features.

Our engineering team is actively investigating the root cause and working to restore full functionality as quickly as possible. We’ll continue to share updates here as we learn more.

We apologize for the disruption and appreciate your patience.
Posted Apr 29, 2026 - 10:50 EDT
This incident affected: Online Ordering (Mobile App, Web Ordering), Communications (Messaging Service, Offer Service, Loyalty Service), and Admin Dashboard, Gift Card Service, User Service.