Our engineering team identified an issue related to recent Spreedly security certificates that prevented any new credit or debit cards from being added or used for orders at checkout. They have updated the security certificates and guests should no longer receive an error message when attempting to place their order.
We will continue to monitor the situation for any ongoing issues.
Posted Jun 21, 2025 - 15:47 EDT
Identified
Our engineering team has found the underlying cause of the issue, and they are currently working on a fix to resolve them. We will continue to provide periodic updates as solution becomes available.
Posted Jun 21, 2025 - 13:55 EDT
Investigating
We have identified an issue related to payment authorization for customers placing orders, and we are currently investigating the issue to determine the cause of the error. We will provide an update as soon as we have more information.
Posted Jun 21, 2025 - 13:07 EDT
This incident affects: Online Ordering (Mobile App, Web Ordering).