Platform Service Disruption

Incident Report for Incentivio

Resolved

What happened?
On May 23, 2026, we experienced intermittent order failures across the platform. After investigation, the issue was traced to a connectivity problem between the reCAPTCHA service used in our ordering flow and Google’s reCAPTCHA servers.

What is reCAPTCHA and why do we use it?
reCAPTCHA is a security service provided by Google that helps verify that orders are being placed by real customers rather than automated bots or scripts. It helps protect our restaurant partners from fraudulent orders, spam, and other abusive activity.

What went wrong?
During the incident, the reCAPTCHA service was intermittently unable to communicate with Google’s verification servers. When those verification requests timed out or failed, some orders were unable to complete the checkout process successfully.

Because the issue was intermittent, customers may have experienced inconsistent behavior where some orders processed successfully while others failed.

Monitoring — May 23, 2026, 6:28 PM
Platform functionality has been restored, and we are actively monitoring system performance to ensure continued stability.

Resolved
All platform services have been verified as stable and operating normally.
Posted May 23, 2026 - 14:00 EDT